Facebook Email Pinterest Twitter Instagram YouTube Icon Headphones Icon Favorite Navigation Search Icon Forum Search Icon Main Search Icon Close Icon Video Play Icon Indicator Arrow Icon Close Icon Hamburger/Search Icon Plus Icon Arrow Down Icon Video Guide Icon Article Guide Icon Modal Close Icon Guide Search Icon

Conversational Threads

rowenta steam iron

User avatar
clairezbo | Posted in General Discussion on

I have the pro model Rowenta steam iron. I have cleaned it but it still wont steam. When I hit the steam button i get a burst of steam, but no steam when I am pressing a seam???????????? Got any sugestions??????. This is the second Rowenta I have paid of 100$ for, so I am not too happy with the product.

Replies

  1. starzoe | | #1

    My first Rowenta lasted about 13 years. It still works but the handle gets hot (dangerous!). I bought one, took it back, didn't work properly, got a replacement, ditto. So I have given up on Rowenta, now have a Velocity which works very well but drives me nuts with the beebbeepbeep and the auto shutoff.

  2. JeanM | | #2

    I absolutely love my Rowenta Pro iron.  I have never had any problems with it and I have had it for about 15 years.   Sorry to hear you ladies are having/had  these problems.  I just looked in my booklets to find out if there was any info on not getting steam while ironing but there really isn't a troubleshooting section.

    The only things I can think of probably wouldn't apply, clairezbo, as you are getting some steam.  If you weren't getting any steam, then I could make some suggestions as to what the problem might be.  Sorry.

    You might visit their internet site which I assume they have.

    1. User avater
      clairezbo | | #4

      I tried the internet site for Rowenta, and for some reason every time I go to the question and answere section, it kicks me out, and I lose the site???? Very strange. Sometimes the soultion is easier if it didnt steam at all. But it has me baffeled because of getting the burst of steam when I hit the burst button. the spray button also works just fine.  When it burst, the steam is clean, no residue.

      1. sewelegant | | #5

        My Rowenta has a lever to move for steam that is separate from the burst and spray buttons.  If it is not pushed down it will not steam.

        1. User avater
          clairezbo | | #6

          Yes, mine does also, it is pushed as far as it will go. Still no steam when pressing

          1. sewelegant | | #7

            I think you must have a faulty iron.  Can you return it to the place where you got it?  It's a shame we have so many products these days that do not have good quality control.  Someone said it is cheaper for them to replace faulty products than hire the help needed for the QC.  Isn't that a sorry statement?  It just reminds me again to save all my receipts.

  3. Crazy K | | #3

    I have one and love it...........but I have had times where I didn't think I was getting steam............only to realize that I had shut the steam adjustment to "min" and forgot to put it back to 'max'!!  Since you get a burst, could that be the problem?

     

    Kay

This post is archived.

Threads Insider

Get instant access to hundreds of videos, tutorials, projects, and more.

Start Your Free Trial

Already an Insider? Log in

Subscribe to Threads today

Save up to 42% and get a free gift

Subscribe

Conversational Threads

Recent Posts and Replies

  • |
  • |
  • |
  • |
  • |
  • |

Threads Insider Exclusives

View All
View All

Highlights

Shop the Store

View All
View More